Tag Archives: ghz

The trials of moving from 2.4GHz to 5.0GHz on your wifi network.

I’ve had strange wifi issues over the last year or so. The first issue was that streaming from my network attached Drobo to my AppleTV3 slowed down tremendously. So bad that every 5 to 10 seconds the AppleTV would catch up to the stream and stop. At first simply hardwiring either my laptop or the AppleTV would solve the problem, but as the year progressed, even that wouldn’t work. Every time I wanted to stream HD video I would have to run a wire from my switch to my AppleTV, and if my laptop was in the living room, run a wire from the switch to it as well. I actually have two long cables wrapped up next to the switch so they are at the ready when I want to watch something. Strangely enough, streaming Netflix and Amazon Prime really had no problems except on the Xbox360.

The newest issue has been my Nest thermostat going offline. This has been happening more and more lately. When I looked for solutions online, the answer seemed to be to create a static DHCP address for the thermostat on the router so the Nest would receive the same internal IP address each time. That did help but it has still disconnected once or twice since I used that workaround.

The latest thing that made me change up my network was that I checked my wifi connection on my 2013 retina MacBook Pro and instead of being connected at 802.11ac, it was connected to my router at 802.11n. Doing some research online I saw many people complaining about retina MacBook Pro wifi connection issues. As far as I know, I haven’t had any major issues, but one seemed plausible. The person said if their laptop goes to sleep, when they wake it up, instead of connecting at 802.11ac, it connects at 802.11n. They have to turn off the wifi on the laptop & reconnect in order to get an 802.11ac connection back. I tried it & it worked, I got an 802.11ac connection. I don’t usually put my laptop to sleep but I recently did. One of the other solutions was to go into the router settings and give the 2.4GHz network a different name from the 5GHz network. That way the laptop would always connect to the 802.11ac network; I thought I’d try that. The first thing I did was audit my wireless devices to see what kind of problem I’d have getting rid of my 2.4GHz network.

My wifi network looks something like this:
Main Airport Extreme (802.11ac) router
– Nest Thermostat
– Canon Printer
– Wii
– AppleTV (3rd gen)
– A Toshiba Blu-Ray player
– an Xbox 360 slim

Airport Extreme (802.11ac) that extends the network
– Dropcam

Devices that routinely travel between these two routers
– MacBook Pro
– iPhone 6
– iPhone 5
– iPad mini (1st gen)

The MacBook Pro & iPhone 6 are 802.11ac which is what I primarily cared about, call me selfish. The iPhone 5, Nest, Dropcam, Printer, AppleTV, Blu-Ray player, Xbox 360, and iPad mini are all 802.11n which also supports the 5GHz spectrum. The only thing requiring a 2.4GHz signal was the Wii which I barely ever use and Nintendo has all but shut down the services for it. I was willing to make that sacrifice to get rid of the 2.4GHz network. My plan was to just shut off the 2.4GHz band altogether but Apple doesn’t allow this. The best I could do was to rename the 2.4GHz network and and give the 5GHz network the original SSID name. MAGIC, right? The router will reboot and all of the devices will still connect to the network, but they’ll be running at 5GHz, theoretically giving me better speeds on a less congested frequency. Well, not quite. What I wasn’t aware of is that some manufacturers skimped on their 802.11n chip specification and only support the 2.4GHz frequency instead of both 2.4GHz & 5GHz. The main router rebooted and then I configured the router that extends the network to the same configuration.

My laptop and iPhone 6 were online. Check.
The AppleTV was connected. Check.
The iPhone 6 was connected. Check.
The Dropcam was streaming again. Check.
iPad mini online? Check.

And then the problems started…
Nest thermostat:
Could I access the Nest thermostat from my phone? No. I walked over to the Nest and it reported that it was disconnected from the network. A quick search showed that while it was 802.11n capable, it only connected at 2.4GHz. I was surprised as others were. Going into Nest settings, I chose the new name for the 2.4GHz network, started up 1Password on my phone, loaded up the secure note that contains my 60-some characters of gibberish wifi password and proceeded to spin the Nest dial to enter it in. It took me 3 tries. 1Password locked itself a few times due to inactivity as well. It was painful. The Nest only connects as DHCP so there were no network settings to adjust.

The Canon printer: I’m sure I read that this thing connected to 5GHz networks. Oh well. I went into the settings, selected the new 2.4GHz network, and entered the password from hell into their slightly better interface than the Nest. It only took me twice to enter it correctly on the printer, and thankfully, I was able to edit my existing entry the second time which saved me a bunch of “typing” as I had only forgotten one character in the password the first time. Upon connecting, the printer remembered its static network settings. Again, a pleasant surprise.

Toshiba Blu-Ray player: I honestly didn’t expect much from this device as it really wasn’t top of the line. It was purchased so company we had over didn’t have to wait for discs to be ripped before watching something on the TV. When I turned the player on, it reported that it didn’t have a network connection. My 5GHz network was pre-selected in the list, so I confirmed, and the Blu-Ray player connected right up. I guess it just wanted some emotional support.

Xbox 360 Slim: This might’ve been the biggest pain next to the Nest thermostat. Why did Microsoft skimp on the wifi for their console? Apparently the USB to wifi adapter one can buy for the Xbox 360 does connect to the 5.0GHz spectrum, just not the built-in wifi chip. I head over to the settings, and my network is already selected. I select it, perform a connection test, and it fails. I have to “forget” the old network which caused a re-scan of the networks in the neighborhood. I selected the newly named 2.4GHz network, entered the password (twice! or was it 3 times total? Once, I accidentally hit the Cancel button which wiped out my entry that was 2/3 done.) After it connected (and performed a system update), I checked the network settings and they were all set to DHCP. To my surprised the static settings were still there, they just weren’t selected. Changed to static network settings and it was back up and running.

The Wii: The Wii! I had completely forgotten about the Wii for an hour or so! I guess maybe I should just unplug it. I only keep it around to play the virtual console games that I bought to remind me about the good old SNES days. I tried to fire up the Wii but it wouldn’t turn on; of course I suspected dead batteries. I opened up the Wiimote to find the batteries corroded, it had been so long since the Wii was used. I replaced the batteries (a second time) and was able to turn on the Wii. I went into the network settings and saw it was still set up with the original network name. I tried the network test which, of course,  failed. All I had to do was enter the new 2.4GHz network name and all was well. It passed the network test. I didn’t have to adjust any network settings nor re-enter my mega-password.

Everything seemed to be working again but I wanted a sanity check. With my printer on, I tried to print from my phone to see if it would come up. Yep, my phone saw the printer. This made me happy because I was wondering if the two networks would be segregated like a guest network would be. Thankfully, no. The router merges 2.4GHz b/g/n network and the 5.0GHz n/ac networks together. And then the big test failed. With my laptop wirelessly connected in the living room, I tried streaming a 1080p movie from my Drobo 5N to my wirelessly connected AppleTV. It played 12 seconds and stopped. Just the same as before. My laptop was connected via 802.11ac, and the AppleTV was still on the network. I rebooted the AppleTV. When it came back up it seemed to take a little longer to populate the movies, etc at the top of the screen, but it was obviously on the 5GHz network. I attempted to stream the 1080p movie again, wirelessly, and it seemed to be working fine. I’ll probably conduct a more thorough test tomorrow, perhaps watching the entire movie instead of just a minute or so. As noted previously, the video would cut out less than 30 seconds into the stream.

I now have two 802.11ac devices on 5GHz.
Eight 802.11n devices, three on 2.4GHz and five on 5GHz.
And one 802.11g device on 2.4GHz.

Put another way, instead of eleven devices on the crowded 2.4GHz network I have four, with seven on the 5GHz band. I hope the wifi streaming will be fine now and my Nest thermostat stays online as well.

Have you had similar experiences adjusting your wifi network?